Złe pozycjonowanie osi ramienia serwonapęd Kollmorgen

Mam problem z pozycjonowaniem się osi ramienia nawijarki cewek elektrycznych.
Po wykonaniu homing-u i wykonaniu 30-40 sztuk cewki ramię nawijarki traci pozycję fizyczną 5mm różnicy po 40 sztukach.
Brak jakichkolwiek błędów po stronie automatyki, w monitorze Drive widać że po każdej sztuce kąt silnika delikatnie się dodaje o parę stopni.
Wygląda to tak jak gdyby aplikacja wykonawcza znając punkt 0 bierze pod uwagę te dodatkowe stopnie odkładające się podczas z każdego z cyklu i obraca silnikiem tylko o te brakujące stopnie.
Napęd korzysta z sprzężenia zwrotnego silnika serwo.
Co może być przyczyną gubienia się serwo napędu podczas wykonywania cyklów.

Aplikacja już działa czy dopiero ja uruchamiasz?
Skąd bierzesz pozycje wbudowany w silnik enkoder czy enkoder zewnętrzny?

Dziękuje za reakcje, udało się opanować sytuację. Problemem była mechanika którą jak twierdził mechanik sprawdził.

Czy znalazłbyś chwilę aby opisać na czym dokładnie polegał problem. Takie zamknięcie wątku było by bardzo wartościowe. Jeśli mógłbyś to warto też dodać zdjęcia.

1lajk

Postaram się opisać problem.

Jak widać na zdjęciu mamy tu nawijarkę do cewek elektrycznych, jeden sewonapęd napędza wrzeciono a drugi ramie układania drutu. Problem był w tym drugim. Po wykonaniu 40 sztuk cewki ramię przesuwało się stopniowo 5mm w lewo.
obraz obraz

Podejrzenie padło na luz na wałku pasa zębatego lub uszkodzenie klina wału i koła pasowego.


I tak faktycznie było po ponownym sprawdzeniu przez mechanika (rozpołowieniu maszyny - bardzo trudny dostęp) okazało się że uszkodzeniu uległ klin koła pasowego (na dole), samo koło było na tyle ciasno spasowane że ramię się przesuwało ale po wykonaniu 40 sztuk traciło zadana pozycje.
Pozdrawiam

4lajki

Świetnie! Dziękuję za wyjaśnienie! Teraz temat jest dokończony :smile:

1lajk